I suggest you ...

Allow CNAME entries

Being able to forward your API URL to your APItools URL. Currently it returns a 404. Maybe this is just bug from the refferer URL

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Chris GrantChris Grant commented  · 

        You can get around this by setting a Host header. It's what we've been doing to get around this.

        Our setup:
        haproxy (port 80) -> APITools (port 10002)

        We make requests to subdomain.domain.com but we set the Host header to '{api-tools-id}-anything'.

        Hope this helps!

      • ApitoolsAdminApitools (Admin, Apitools) commented  · 

        We detect the monitor by the URL, so at this moment it wouldn't work.

        We are leaving this open for discussion, ideas, votes. Thanks!

      Feedback and Knowledge Base